Views:

Symptoms

Current vStor appliance v4.7.1 is based on CentOS Linux release 7.7.1908.
Prior vStor appliance v4.6.x is based on CentOS Linux release 7.5.1804.

After a normal vStor v4.7.1 upgrade procedure described in “ReferenceGuide.pdf”, underlying OS version will remain CentOS Linux release 7.5.1804.
 

While vStor functionality is not impacted, it is very desirable to be on the current OS version as it addresses some vulnerabilities.
You can check version of your appliance in vStor GUI on the System tab:


Also, following shell commands can be used to validate appliance version:
[admin@vstor ~]$ cat /etc/centos-release
CentOS Linux release 7.7.1908 (Core)



[admin@vstor ~]$ vstor system show

ID: 050333429f244cb2bff05c851b430b39
INIT STATUS: Ready
REDIS RUNNING: Yes
CELERY RUNNING: Yes
MULTIPOOL SUPPORT: Yes
LOCAL REPL SUPPORT: No
HOSTNAME: vstor
FQDN: vstor
OS NAME: CentOS Linux
OS VERSION: 7.7.1908
API VERSION: 1.3
VSTOR VERSION: 4.7.0-353
NGINX VERSION: 1.12.2-1.el7
UWSGI VERSION: 2.0.17.1-2.el7
NFS VERSION: 1.3.0-0.48.el7_4
REDIS VERSION: 3.2.12-2.el7
SAMBA VERSION: 4.10.4-11.el7_8
ZFS VERSION: 0.8.3.10.1.6-20200511.el7
 

Resolution

This behavior has been addressed in a vStor Maintenance Update. The latest ISO images can be downloaded from the Catalogic Software Online Support site:
https://mysupport.catalogicsoftware.com/product.php/DPX471